Машрутизация с помощью протокола ODR

Опубликовано – 01.12.2009

Автор: Сгибнев Михаил
Конфигурацию написал: Серебряков Дмитрий

 Довольно часто перед сетевыми администраторами встает задача подключения большого числа маршрутизаторов по схеме «звезда». Примером тут могут служить сети банкоматов или миниофисов. Решать проблему маршрутизации в таком случае можно несколькими способами: статические маршруты, какой-либо из протоколов динамической маршрутизации или комбинация уже перечисленного.

 Если наша сеть построена на оборудовании Cisco, то на помощь нам может придти протокол ODR (On-Demand Routing),
являющийся расширением протокола CDP (Cisco Discovery Protocol).

 ODR как нельзя более подходит для маршрутизации на некоторых участках в сетях ритейлеров или банков — там, где есть необходимость подключения множества точек и при этом используются маршрутизаторы SOHO сегмента и/или нет нужды в более мощных протоколах динамической маршрутизации. Если сравнить ODR с другими протоколами динамической маршрутизации, то самым большим его преимуществом будет получение маршрутной информации по 2 уровню, без необходимости наличия маршрутизации на 3-м уровне. Так же, намного меньше используется память и CPU маршрутизатора.

  Основными параметрами, которые могут вам потребоваться при конфигурации ODR являются таймеры update, invalid, hold down, flush:

router odr
timers basic 8 24 0 1

  И список сетей для анонса. В данном примере мы анонсим адреса Loopback интерфейсов со spoke:

router odr
distribute-list 111 in


[ad name=»Google Adsense»]



 Для hub мы будем использовать уже знакомую нам конфигурацию с NHRP, хотя это не принципиально — работать все будет и на физических интерфейсах и на point-to-point туннелях. Если есть желание, то можно изменить таймеры самого CDP.


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname hub
!
logging buffered 1048576 debugging
no logging console
!
no aaa new-model
!
resource policy
!
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
ip icmp rate-limit unreachable 10
!
ip cef
!
no ip domain lookup
!
crypto isakmp policy 10
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set dmvpn esp-aes esp-sha-hmac
mode transport
!
!
crypto ipsec profile vpn
set transform-set dmvpn
!
interface Tunnel0
ip address 10.0.0.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp holdtime 600
ip nhrp cache non-authoritative
ip tcp adjust-mss 1360
cdp enable
tunnel source Vlan1
tunnel mode gre multipoint
tunnel key 1000
tunnel path-mtu-discovery
tunnel protection ipsec profile vpn
!
interface Loopback0
ip address 192.168.100.1 255.255.255.0
!
interface Vlan1
ip address 172.17.0.1 255.255.255.0
!
router odr
distribute-list 111 in
!
!
router ospf 1
log-adjacency-changes
redistribute odr subnets
network 192.168.100.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
access-list 111 permit ip any 192.168.0.0 0.0.0.255
cdp source-interface Tunnel0
!
line con 0
exec-timeout 0 0
transport preferred none
escape-character 3
!
line vty 0 4
exec-timeout 30 0
password cisco
login
transport preferred none
escape-character 3
!
end


 Конфигурация spoke еще более незамысловата. Не требуется абсолютно ничего, кроме включенного CDP — default route передается именно через него.


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname spoke3
!
logging buffered 1048576
no logging console
!
no aaa new-model
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
!
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
vtp mode transparent
!
crypto isakmp policy 10
authentication pre-share
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set dmvpn esp-aes esp-sha-hmac
mode transport
!
crypto ipsec profile vpn
set transform-set dmvpn
!
archive
log config
hidekeys
!
!
interface Loopback0
ip address 192.168.0.3 255.255.255.255
!
interface Tunnel0
ip address 10.0.0.3 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 10
ip nhrp holdtime 300
ip nhrp nhs 10.0.0.1
ip tcp adjust-mss 1360
cdp enable
tunnel source Vlan1
tunnel destination 172.17.0.1
tunnel key 1000
tunnel path-mtu-discovery
tunnel protection ipsec profile vpn
!
interface Vlan1
ip address 172.17.0.3 255.255.255.0
!
no ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
cdp source-interface Tunnel0
!
line con 0
exec-timeout 0 0
transport preferred none
escape-character 3
!
line vty 0 4
exec-timeout 30 0
password cisco
logging synchronous
login
transport preferred none
escape-character 3
!
end

Используемая литература:
Designing Large-Scale Stub Networks with ODR
ODR: Frequently Asked Questions

 Уважайте труд автора, сохраняйте копирайты.
Реклама на сайте висит не просто так и если статья Вам понравилась, с ее помощью Вы можете отблагодарить автора за проделанную работу. Спасибо!


[ad name=»Google Adsense»]


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*